We're back! New secure web server is online   Read More
TRExp

Spitfire & GT6 Forum

spitfire transmission

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

jamesregis Avatar
jamesregis Gold Member Jim S
Kettering, OH, USA   USA
My transmission shifts through all 4 gears just fine, but when I try to down shift into 3rd gear It won't go and the gears grind. Any Ideas what might be wrong? My car is a 1972 model.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
Doug in Vegas Avatar
Doug in Vegas Douglas D
Las Vegas, NV, USA   USA
Assuming no clutch you must rev the engine before catching the lower gear.

Takes practice.

14GPDJENGINEERING Avatar
Silver Spring, MD, USA   USA
Broken Mainshaft snap ring.

See this: http://www.triumphexp.com/phorum/read.php?8,1511028



Dennis smiling smiley

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
kaatmanduu Avatar
kaatmanduu Silver Member Mike Stevens
Grass Valley, CA, USA   USA
Could be a dragging clutch too. Are you having problems with any other gears? Does it go into reverse easily?

jamesregis Avatar
jamesregis Gold Member Jim S
Kettering, OH, USA   USA
Thanks Dennis, I checked out the discussion you referenced and I will check out the circlip. Jim

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions




Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster