Visit our Twitter feed for more great content
TRExp

TR7 & TR8 Forum

No accelaration or power

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

Rburgess Avatar
Rburgess Randy Burgess
Fresno, CA, USA   USA
Thank you David. I purchased a piece off of eBay some time ago. I will make note of this for future reference.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
dhuddleson Avatar
dhuddleson David Huddleson
Manotick, ON, Canada   CAN
VW bus is also a source for compatible EFI fuel pumps! The hose must be reinforced so it does not collapse under suction from the fuel pump.

Rburgess Avatar
Rburgess Randy Burgess
Fresno, CA, USA   USA
David,
I purchased the correct hose from eBay some time back but thank you for your advice. Should I need to replace this hose again in the future, looks like I have more options.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
terryjm1 Terry Merrell
Saint Louis, MO, USA   USA
Hello Gary,

The Bosch ECU in the TR7 is a much more solid unit than the TR8 Lucas unit. It is rare to have a problem with them and I doubt that is your issue. My understanding is Triumph wanted to buy the TR8 ECU from Bosch (like they did for the TR7) but Bosch wasn’t making V8 ECUs at that time. The ECU used in the TR7 is nearly the same as every Bosch ECU produced at that time and used by many manufacturers. It is remarkably reliable.

That chamber is just to allow blow by to be fed back into the plenum to be reburned. It is a sort of catch can.

Double check there isn’t an issue with the cap, rotor, and wires. Swap them out with a known good set.

Did you have the fuel tank resealed / coated? I had problem with one I had resealed. About a month after installing the tank, it had clogged up a new filter and caused issues similar to what you describe. I don’t know what happened in the tank but after that initial issue I have had no problems. It cost me one filter.

Additionally, I had an air flow meter go bad that caused similar issues. I swapped the one from my other TR7 and the problems disappeared. It was quicker and easier to do that than go through all the diagnostics.

(Lol, just realized the were 3 pages on this post. Sorry for repeating what others stated. It is early... and I am getting old)



Edited 4 time(s). Last edit at 2019-01-24 07:17 AM by terryjm1.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions




Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster