TRExp

Spitfire & GT6 Forum

Bad choke?

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

Bad choke?
#1
  This topic is about my 1970 Triumph Spitfire MkIII
techwiz001 Matthew S.
Winston-Salem, North Carolina, USA   USA
Hello everyone!
I have a 1970 Spitfire MkIII, and with the recent colder weather, I have had some issues driving right after startup.
With the idle speed screw tightened enough for the car to hold an idle when it is started from cold, it idles at about 1700rpm once it has warmed up.
My understanding is that this may be due to a failure in the car's electric choke (it has a Weber carb), but I am not totally sure. How can I verify that this is the issue? Is there anything else that could cause this?
Thanks for your help.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
Yellowhawk Valley Avatar
walla walla, washington, USA   USA
1969 Triumph Spitfire "Walla Walla"
1969 Triumph Spitfire "Portland"
1972 Triumph Spitfire MkIV "Spokane"
1975 Triumph Spitfire 1500 "Dayton"    & more
Not sure how the electric choke works on those carbs but often you can just unplug it and it will go full open. Or, just loosen the clamps and make sure it is full open when it is fully warmed up by adjusting it.
When it is fully warmed, does quickly tapping the throttle release the fast idle set? If not, that may be where your adjustment needs to be done.
Dan

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions

Members Sign In   or   Create an Account

Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster