TRExp

TR2 & TR3 Forum

After 50 years of ownership....

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

Starshark Avatar
Starshark Joe Garcia
Gainesville, Georgia, USA   USA
1960 Triumph TR3A "White Knight"
After 50 years of ownership, I finally, no kidding, fixed all the ()&&*(^%$ leaks. Macy's Garage of Tipp City OH rebuilt my Trani (TR-4 trani which was purchased in 1977 used from JC Whitney!) and fixed my vibration issue by correctly installing / seating the throw out bearing collar. I installed a niffty rear engine seal while not having to remove the engine nor having the crank machined. (Also purchased from Mark Macy). I replaced the lower main bearing cap found while installing the rear engine seal. Whew! Check this out...
http://homemagazinenorthgeorgia.com/2017/a-major-triumph-joe-garcia-celebrates-50-years-owning-his-british-roadster/

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

Attachments:
20170918_160420.jpg    37.5 KB
20170918_160420.jpg

Garcia-0050s.jpg    22.8 KB
Sign In or Register to view this photo
20170911_140625.jpg    55.4 KB
Sign In or Register to view this photo
Starshark Avatar
Starshark Joe Garcia
Gainesville, Georgia, USA   USA
1960 Triumph TR3A "White Knight"
50 Proof: 23 year old me with car...June 1970..note oil stains on pants...then me today...


Attachments:
FB_IMG_1499034316325.jpg    44.6 KB
FB_IMG_1499034316325.jpg

HOMEcar1.jpg    67.9 KB
Sign In or Register to view this photo
Jacad Avatar
Jacad Gold Member Barry Shefner
Montreal, QC, Canada   CAN
1959 Triumph TR3A "Loose Wheels"
1976 Triumph TR6 "The Tweetster"
Congrats Joe! ........ wish you another 50 years of joy with your car ... you should be so lucky as to have oil stained pants in 2067smiling smiley



Barry
59 TR3A 0TS57675LO - "Loose Wheels"
76 TR6 CF54266U - "The Tweetster"
Website: Triumph TR2-TR3-TR4 www.trtriumph.com/ (sorry for not keeping it current for the past couple of years)

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
Starshark Avatar
Starshark Joe Garcia
Gainesville, Georgia, USA   USA
1960 Triumph TR3A "White Knight"
Only one big problem...the darn car is shrinking! But my wife likes it.


Attachments:
20150511_194458.jpeg    44.3 KB
20150511_194458.jpeg

IMG00153-20110703-1114.jpg    60.9 KB
Sign In or Register to view this photo
ShortBulge Brian LeBlanc
Falls Church, Virginia, USA   USA
Obvious ...which 1 is holding up better...besides 3 !

CJD john durant
Southlake, Texas, USA   USA
How will you know it has oil now?



John
Southlake, TX

'55 TR2

mgedit Mike Graham
Kemptville, Ontario, Canada   CAN
Congratulations! Cheers, Mike

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
JoeOtero Avatar
JoeOtero Joe Otero
Lexington, Kentucky, USA   USA
1963 Triumph TR3B
1968 Triumph GT6 MkI "Cali"
1972 TVR Vixen
Congrats Joe! Always good when your life partner likes the things you enjoy..!

Cheers

Joe O

TuRtle5 Avatar
TuRtle5 Kevin Kelly
Absecon, NJ, USA   USA
1949 Triumph 2000 Roadster "Coral Mistress"
1959 Triumph TR3A "Drandulet"
1962 Triumph Vitesse "Ohtoseethelightofday"
1968 Triumph TR250    & more
now Joe will have to start doing oil changes.
K

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
Starshark Avatar
Starshark Joe Garcia
Gainesville, Georgia, USA   USA
1960 Triumph TR3A "White Knight"
Thanks for the comments...

I need some "guidance" re: vacuum advance...I have the original distributor (V202 960 with DM2 vac unit) installed. It's only a few years old (57 years) and I do want to keep everything as original as possible so no electronic Moss solution for me...I know the mechanical advance works since I can see it work with a timing light...yes, I still have my Sears Penski chrome timing light...I have an acceleration "hesitancy" so I believe; a) I have a plugged / inop vac advance suction vacuum line/tube from the carb to the distributor, b) a leak at the tube/dist. rubber attachment (note the black tape), c) a bad vacuum unit or ...d) all of the above. I checked the oil in the carbs (I can't believe I said that) and carb dampers work fine.

Any words of wisdom before I tear into my issue?

Joe


Attachments:
20171015_111231.jpg    41.7 KB
20171015_111231.jpg

20171015_111217.jpg    30.9 KB
Sign In or Register to view this photo
20171015_111224.jpg    24.2 KB
Sign In or Register to view this photo
20171015_111407.jpg    36.9 KB
Sign In or Register to view this photo
. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions

Members Sign In   or   Create an Account

Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster