TRExp

TR7 & TR8 Forum

Need help putting my wiper switch back together

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

76tr7rules Anthony Perna
Paramus, NJ, USA   USA
I had some free time today and no money so I figured Id try to fix something on the car for free. My wiper switch was hard to move and the mist setting didnt work. So I took it apart today. As I was trying to get the stalk out the whole switch basically flew apart before I could get a good look at it. I greased it and tried to put it back together but I cant get the big brass spring that sits under the stalk back in. I just cant figure out how to get it to set back up in the switch. I put it back together with out it, and it works so smooth except you can slide it down to the most setting when you go to shut it off, and the mist setting still doesnt work.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
nick Avatar
nick nick m
Bend, OR, USA   USA
Hope this helps.



nick


Attachments:
Nov20110005.JPG    25.5 KB
Nov20110005.JPG

Nov20110006.JPG    21.6 KB
Sign In or Register to view this photo
76tr7rules Anthony Perna
Paramus, NJ, USA   USA
Thank you the picture worked like a charm. I cleaned all the contacts with brake clean on a rag, then scuffed them with a scotch brite pad, then spread and greased the spring inside the stalk and smeared red and tacky on all the friction points, the stalk spring, and lightly on the contacts. The switch works perfect. Who knew a loose non working switch would come back to life so well...

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
Tri-Al Avatar
Tri-Al Al Markowski
Cleveland, OH, USA   USA
Your drawing is BRILLIANT! This is just what I need.....I hope. Could Not figure out how that spring went in. This just might be the answer. Gotta go try it!

Tri-Al Avatar
Tri-Al Al Markowski
Cleveland, OH, USA   USA
Success! Your drawing worked like a charm! Good it go! It works! No need for a new one! So glad I discovered this site!

ANDRE7 Andrew P
Montauban, France   FRA
THANKYOU NICK this post has been a life saver excellent
I repaired the switch in 10 mins that spring had me foxed
thanks to all who answered my call fo help
andy

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions




Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster





Join The Club

Sign in to ask questions, share photos, and access all website features

Your Cars

1978 Triumph Spitfire 1500

Text Size

Larger Smaller
Reset Save

Sponsor Links