TRExp

Stag, 2500 & 2000 Forum

Stag oil ump

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

sagreenwoo Stuart Greenwood
San Diego, California, USA   USA
When I rebuilt my engine I fitted a County oil pump
I have done 2000 miles since the install
Three weeks ago I was out on a run and the oil pressure started to drop and eventually went to zero at idle.
when I removed the oil pump I found that the steel bush that the relief valve slides in had come adrift from the housing
This was because the bush had not been staked in place
When this bush comes out of the housing it is jus like the relief valve being fully open
If you purchase a new oil ump ( County is the only option I'm aware of) before you fit it check that the bush is staked in place and, while you are at it, check all the clearances as per the ROM

Stuart

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
troppojohn Silver Member John Peers
Tinonee, N.S.W, Australia   AUS
Hi Mate I have a 77 Stag and it normally runs about 25 PSI above 2500 RPM when warm and can drop to 10 to 12 psi at idle, Just woundering what your normal oil pressure was before the pump failed.

Thanks

John

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions

Members Sign In   or   Create an Account

Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster