TRExp

Triumphs List Archive

stuck TR4A bonnet

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

mailbot Avatar
mailbot Mail List Archive Bot
The Interwebs, USA   USA
This read-only message was archived from a public mail list.
Mail From: carlsereda <(email redacted)>

Peter,
Guessing a little here - the head of bonnet plunger may have not been
centered exactly and is snagging off to the side of its receiving
hole.
You might try having someone pull both release cables whilst you
firmly jostle the bonnet around by the eyebrows (attempting to jar the
plunger forward and back, and side to side, to uncatch head of plunger
from side of hole.. otherwise you may have to start taking things
apart behind cubby box to do the same..
Good luck,
Carl
'63 TR4 since '74

On Aug 30, 2010, at 11:00:03 AM, (email redacted) wrote:

Pulled the bonnet release cable today and much to my dismay the bonnet
did not
open.
I then reached for my backup cable and still no good.
Both cables have tension on them and I believe I hear the latch move.
I find it hard to believe both would fail simultaneously.
I have tried to push down on the center of the bonnet near the latch
but no
there is no play or spring whatsoever.
I'm suspecting the spring has gone out of alignment(?).

What would you recommend as next steps?

_______________________________________________
(email redacted)
Donate: team.net/donate.html
Suggested annual donation $11.47
Archive: team.net/archive
Forums: team.net/forums


. Hide banner ads & support this website by becoming a > Gold Supporting Member <

Sorry, you can't reply to this topic. It has been closed.


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster





Join The Club

Sign in to ask questions, share photos, and access all website features

Your Cars

1964 Triumph Spitfire MkII

Text Size

Larger Smaller
Reset Save

Sponsor Links